Members Login
    Remember Me  
Post Info TOPIC: A way around UAC Prompts?

A way around UAC Prompts?

Hello everyone,

I am currently trying to package logitech options using the offline packager and a clean virtual machine to use it on the go on a foreign computer.

When I try to start the packed application, it asks for admininstrator privileges. The normal application does not do this and if i extract it from the Cameyo package, it works as intended. if I deny the UAC prompt, it either gives me a Error 740 or a Error 0, if I elevate the package, it starts up normally.

If I inject a standalone .exe into the same package and order it to start from there, cameyo has no problem opening it, without elevation.

I already tried pretty much every option in the packager, tried to force "RUNASINVOKER" through the registry and used -remove on the package.

Ialso generated some logs with -Troubleshoot, but cannot understand, why it calls 'RunElevated' on the program (links in the end).

I am using windows 10 1803, cameyo packager 1.0 and logitech Options_8.36.86


Btw, some time ago, I managed to do this without admin privileges, so i know its Possible. But of course, i cannot replicate it anymore...

Error 0:

Error 740:


Best regards, Mika



Veteran Member

Status: Offline
Posts: 32

Create a .bat same folder in the apps directory. Than Just drop the program on the bat.

cmd /min /C "set __COMPAT_LAYER=RUNASINVOKER && start "" %1"

Page 1 of 1  sorted by
Quick Reply

Please log in to post quick replies.

Create your own FREE Forum
Report Abuse
Powered by ActiveBoard