Cameyo

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Portable application require Administrator right to run


Newbie

Status: Offline
Posts: 3
Date:
Portable application require Administrator right to run
Permalink   
 


Dear

 Cameyo has wonderful tool - Cameyo Packager and it 's all that we need.

In fact, i have problem when running portable application which will describe below :

-First step : i have made portable application and include .NET (ver 4.5.1) in its. ( by install .Net 4.5.1 when capture installing)

-Second step :  Running Portable application with Administrator right, the portable works well and use included .Net framework correctly.

-Third Step ( the problem here  ):  if running portable application with normal user right, the portable can not found .Net framework and can not run. 

Please help me how to fix this.

Many thank for your support.  

 



__________________


Guru

Status: Offline
Posts: 886
Date:
Permalink   
 

  1. Does the program need to run as Administrator when installed natively?
  2. What OS did you use to build package?
  3. Was package built on clean virtual machine?
  4. Are you running package on a system that has had the software installed previously?
  5. If the OS is different from the one used to build the package, what OS is the target system?


__________________


Newbie

Status: Offline
Posts: 3
Date:
Permalink   
 

Dear

@Mule : Thank for your reply

1.  Does the program need to run as Administrator when installed natively?

No, the source program do not require administrator right. it works well with Normal user and admin user

but when install Dotnet framework 4.5, i must have administrator right to do.

2.  What OS did you use to build package?

Windows 7 Ultimate 64bit

3. Was package built on clean virtual machine?

Yes. It 's build on clean Vmware virtual machine. 

My install steps like below : 

install clean windows 7 --> [open Cemeyo to record before install] ---> install Dotnet 4.5 & my application -->[use Cemeyo to record after install] 

4. Are you running package on a system that has had the software installed previously?

yes. may be the system also has Dotnet 4.5 so the portable can work

5. If the OS is different from the one used to build the package, what OS is the target system?

I try to run on windows 2008 r2 (64bit), windows 10 Pro,  windows 2016. All need administrator right if the system does not have Dotnet 4.5

More information : using Microsoft ProcessMonitor, i see that running with administrator right, the portable calls Dotnet registry from something like : REGISTRY\..\[ported Dotnet 4.5]

but running as normal user, cameyo will call Dotnet registry from current windows system.

Hope this can help me and other people facing same problem.

Many thank for your support



__________________


Guru

Status: Offline
Posts: 886
Date:
Permalink   
 

Please package without including .NET Framework in the capture, and test the new package on Win10 and Windows Server 2016.  What are the results?



__________________


Newbie

Status: Offline
Posts: 3
Date:
Permalink   
 

Dear
You are right
After install as your recommend, everything works well
Please closed this topic and marked it as solved
Thank

__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard